È tempo di andare oltre PHP 7.0

cambio PHP 7.1 default

Qualche tempo fa, PHP 7.0 ha introdotto alcuni miglioramenti in termini di prestazioni per tutte le applicazioni web, incluso WordPress. I nostri sforzi, per cercare di diffonderlo il più possibile tra i nostri clienti, hanno portato molti siti a diventare più veloci di prima. Nel frattempo, sono state lanciate due nuove versioni di PHP: 7.1 e 7.2.
È giunto il momento, dunque, di andare oltre la versione 7.0.

PHP 7.1 è ora di default per i nuovi account

La versione predefinita di PHP sui nostri server viene scelta pensando prima di tutto alla sicurezza. Quando una nuova versione è disponibile, siamo subito pronti a renderla disponibile. Grazie alla nostra configurazione del server, che consente più versioni PHP, chiunque è in grado di iniziare a utilizzare l'ultima versione immediatamente dopo il suo rilascio. Tuttavia, siamo anche cauti nello stabilire come predefinita la nuova versione. Cerchiamo sempre di dare tempo ai proprietari dei siti e agli sviluppatori di plugin di rendere il loro codice compatibile con l'ultima versione, prima di fare il passaggio.

Ora che PHP 7.0 non è più supportato attivamente dal team di PHP, abbiamo cambiato la versione PHP predefinita per tutti i nostri server in PHP 7.1. Quindi tutti i nuovi account avranno di default PHP 7.1. Questa modifica non si applica ai siti esistenti e consigliamo vivamente a tutti i nostri utenti di verificare la versione di PHP che utilizzano e di passare a 7.1 (o versione successiva) tramite lo strumento Gestione Versione PHP nel cPanel.

I nostri utenti di WordPress possono anche verificare la compatibilità del proprio sito con PHP 7.1 prima di dare lo switch dal proprio pannello di controllo WordPress, grazie al nostro plugin SG Optimizer. Ti basta andare nella pagina di configurazione PHP in SG Optimizer e avviare il controllo di compatibilità. Semplice e rapido! Per saperne di più puoi leggere il mio articolo dedicato 🙂

Che dire di PHP 7.2?

Al momento, l'ultima versione disponibile di PHP è la 7.2 e ti potresti chiedere perché non abbiamo selezionato quella come predefinita. La ragione è che PHP 7.2, nonostante porti miglioramenti rispetto al suo predecessore, al momento non è ancora largamente supportata. Ciò significa che molti script non funzioneranno correttamente o non funzioneranno affatto. Nel contesto di WordPress, anche se il Core è completamente compatibile (e in realtà raccomanda la 7.2), molti plugin non funzioneranno correttamente al momento. Ecco perché abbiamo deciso di raccomandare PHP 7.1. Dopo che la maggior parte degli sviluppatori di plugin avrà rilasciato il supporto per PHP 7.2, aggiorneremo ancora una volta la nostra versione predefinita e il controllo di compatibilità di SG Optimizer e ti consiglieremo di passare alla 7.2.

Digital Marketing Strategist

Luca è un nativo digitale con la passione per il marketing! Rientra perfettamente nella fascia dei Millennials e si fa portavoce di un mondo che sta cambiando lanciandosi in sfide “markettare” che ci aiutano, attraverso i nuovi media, a essere sempre più presenti e vicini a tutti voi.

Risposta

* (Richiesto)